Import error from Excel-data previously importated without error

Welcome to the forum for MLwiN users. Feel free to post your question about MLwiN software here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Remember to check out our extensive software FAQs which may answer your question: ... port-faqs/
Post Reply
Posts: 1
Joined: Thu Aug 29, 2019 5:16 am

Import error from Excel-data previously importated without error

Post by sglaeser »

I have been using MLwiN 2.02 and importing data from Excel with no problems until today. Yesterday, I imported and ran models all day, then today I can not import new datasets or even ones that that previously imported without issue. I've checked FAQs, the manual, and a few hours of searching for the cause. I've reinstalled, restarted, tried a clipboard wipe, and tried only partial data. Here are my steps so it's clear I am doing it correctly:
1. Select the data with first row as column headers
2. Crtl+V
3. Check "User first row as names"
4. Check "Free Columns
5. Paste
Error is "file does not exist (OBEY)".
I think this simply means that I wasn't able to create a data file.

It may be that an upgrade would solve the problems but I am at the end of hundreds of hours of modelling and writing a manuscript and I don't want to change versions now. Any other ideas would be so much appreciated.
Kamala-Data for GLMM.xlsx
(1.11 MiB) Downloaded 77 times

Posts: 1182
Joined: Mon Oct 19, 2009 10:34 am

Re: Import error from Excel-data previously importated without error

Post by ChrisCharlton »

As part of the process of pasting data into MLwiN it writes a temporary macro using the ASSI command to read in the data. For current versions this is written to the Windows %TEMP% directory, however I think that back in 2.02 this may have used the application directory instead. If you open the Data Manipulation->Command Interface window and uncheck User you should be able to see the command where this is happening, including the temporary file name. You could then check that you are able to write to the directory and whether the files that it references exists. It should be deleted after a successful paste operation, but something may have prevented this.

Post Reply