[SOLVED] design vector at level 2 is the wrong length

Welcome to the forum for MLwiN users. Feel free to post your question about MLwiN software here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Remember to check out our extensive software FAQs which may answer your question: http://www.bristol.ac.uk/cmm/software/s ... port-faqs/
Post Reply
Posts: 18
Joined: Thu Feb 06, 2014 9:37 am

[SOLVED] design vector at level 2 is the wrong length

Post by kaiserdominici »


It was indeed the missing data. Once I listwise-deleted them and tried again building up from an empty model, it worked. Original post below.


Hi all,

I was trying to reproduce the procedure in Chapter 5 in the Manual Supplement to MLwiN (http://www.bristol.ac.uk/cmm/software/m ... nt-web.pdf) using my dataset.

I get the error in the Subject when I run the command "star" to start the model. I read in a previous post that this may be due to missing data, and indeed my model uses 259 out 320 cases. Some info on the model:

Code: Select all

y_ij = β_0j + β_1j x t_ij + β_2 x t_ij^2 + ε_ij
β_0j = β_0 + υ_0j
β_1j = β_1 + υ_1j
Where y is a continuous variable, i are measurement occasions and j is an individual, and t is a time variable that goes from 0 to 4, and it has also been squared to investigate acceleration in growth. Since not all individuals took all measurements, there are some missing values at level 1. Since it is a repeated measures dataset, I wanted to try and allow for AR(1), hence my reference to that chapter in the manual.

Many thanks for any help :)

Post Reply