Error message for categorical variable imputation

Welcome to the forum for REALCOM users. Feel free to post your question about REALCOM here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Go REALCOM (Developing multilevel models for REAListically COMplex social science data) >> http://www.bristol.ac.uk/cmm/software/realcom/
Post Reply
AyaH
Posts: 7
Joined: Tue Oct 11, 2011 5:30 pm

Error message for categorical variable imputation

Post by AyaH »

Hi.
I have been having a problem to impute some categorical variables. These variables have 4, 10, and 12 categories. Ideally, I would like to use m. as they are not strictly ordered, but could do with o.
The problem is that both o. and m. do not work for all these three variables.
For example, a variable with 4 category having 23 % missingness, and there is no category with having extremely small number of samples. But the REALCOM displayed a message "??? Error while evaluating uicontrol Callback", and did not start iteration process.
Other variables were similar regardless of the number of categories (even did not work when I made one of them into 2 category variable).

If you have encountered similar problems, please help me.

Also, is there any way to use dummy variables to impute by REALCOM?
I tried, but it seemed all dummy variables are independently imputed...

Best wishes,
Ayako

Harvey Goldstein
Posts: 49
Joined: Sun Sep 06, 2009 5:30 pm

Re: Error message for categorical variable imputation

Post by Harvey Goldstein »

Regarding dummy variables, you must enter a multicategory response as a single variable with categories coded as integers starting at zero.
Harvey Goldstein

AyaH
Posts: 7
Joined: Tue Oct 11, 2011 5:30 pm

Re: Error message for categorical variable imputation

Post by AyaH »

Thank you for the reply.

I am sorry for unclear explanation, previously.
I have been using multicategory variables as response variables. But, as they were never accepted except for 1 ordered categorical variable, I thought of trying to use dummy variables to impute these unaccepted categorical variables. But yes, it was not appropriate and did not work.

I have been still having a trouble to impute ordered and unordered response variables. REALCOM only accepts 1 particular ordered variable, but not others. They starts from 0, all values are integers, and their number of categories are 4, 10, and 12, respectively.

What are wrong with these variables?

Best wishes,
Ayako

Harvey Goldstein
Posts: 49
Joined: Sun Sep 06, 2009 5:30 pm

Re: Error message for categorical variable imputation

Post by Harvey Goldstein »

If you send me the data you are trying to use with realcom I will look into this

h.goldstein@bristol.ac.uk

Jamoo
Posts: 36
Joined: Wed Oct 05, 2011 2:33 pm

Re: Error message for categorical variable imputation

Post by Jamoo »

AyaH wrote: But the REALCOM displayed a message "??? Error while evaluating uicontrol Callback", and did not start iteration process.
Other variables were similar regardless of the number of categories (even did not work when I made one of them into 2 category variable).

If you have encountered similar problems, please help me.
Hi AyaH,

I've had similar errors to this when Realcom was installed on a drive which I didn't have permissions to write to.

Hope this helps,

Jamie

AyaH
Posts: 7
Joined: Tue Oct 11, 2011 5:30 pm

Re: Error message for categorical variable imputation

Post by AyaH »

Dear Jamoo

Thank you so much for your posting.

I have updated the REALCOM a few days ago, and it keep giving me this message.
Yes, the drive to which the REALCOM installed might have problem on permission (though I am not entirely sure).
In general, I was advised to used other drive for my daily work.

Thank you so much.
I will see it.

AyaH
Posts: 7
Joined: Tue Oct 11, 2011 5:30 pm

Re: Error message for categorical variable imputation

Post by AyaH »

I have got permission of access to the drive, and I treid even with my laptop (which I would have access to any drives), but the REALCOM keep giving me the below error message.

It is like:

??? ?C? "?f?b?N?X?a?s?n?I????3?d"
?G?%?[ ==> sampleymiss at 77
....(several similar messages)
??? uncontrol Callback ?I?A?s' +?E?G%?[?a" -?

Previously, this error message seemed to have occurred when more than 1 categorical variable were involved, so I reduced the number of categorical variable being imputed to one, and then it worked.
Now, even if I change my model so simple like only 3 continuous variables, but still it does not work.

I do appreciate if somebody give me advice.

Jamoo
Posts: 36
Joined: Wed Oct 05, 2011 2:33 pm

Re: Error message for categorical variable imputation

Post by Jamoo »

Dear Ayah,

An updated version of realcom is now downloadable. It might be worth downloading this and checking whether you still get the error as I think a bug was fixed regarding the handling of categorical variables

Best wishes

Jamie

AyaH
Posts: 7
Joined: Tue Oct 11, 2011 5:30 pm

Re: Error message for categorical variable imputation

Post by AyaH »

Dear Jamie

Thank you so much for your suggestion, but I have updated the REALCOM last week, and the error messages are from updated REALCOM.
It might be my silly mistakes, but as far as I see, the syntax I used (and got the error message) was working untill the moment before I update the REALCOM..

Thank you,
AyaH

Post Reply