Page 1 of 1

start up problems

Posted: Fri Jul 19, 2013 5:30 pm
by caroline1
Hi everyone,
I'm new to using this software, and have installed MATLAB runtime installer for Realcom and REALCOM Impute.
I went through all of the steps to load the data from Stata, view equations, set the MCMC settings successfully. However, when I went to "Start MCMC run" button, it ran for awhile until it got up to iteration 1100. Then, I get a series of error messages:

Error using save
Unable to write file storedata: permission denied

Error in mcmcdriver (line 1192)

error in gui_2levmixresp>pushbutton16_RunMCMC_Callback <line 264>

Error in gui_mainfcn <line 96>

Error in gui_2levmixresp <line 46>

Error in @<hObject,eventdata>gui_2levmixresp<'pushbutton16_RunMCMC_Callback',h0bject,eventdata,guidata<h0bject>>

Error while evaluating uicontrol Callback

Any ideas on how I can fix these errors?


Re: start up problems

Posted: Mon Jul 22, 2013 9:59 am
by ChrisCharlton
When you run a model using Realcom it attempts to write some information to files in its current directory, which by default is under c:\program files\. Normal users cannot usually write to directories in this location so to enable it to work you will need to do one of the following:

1) Run with an account that has write access to that directory (i.e. has administrative privileges).

2) Install Realcom into a directory that your username has write access to

3) Change/Create a new short cut to the Realcom executable with the working directory set to a location that you can write files to.

Re: start up problems

Posted: Tue Jul 23, 2013 5:45 pm
by caroline1
I made those changes and it seemed to run successfully. Thank you so much for your help!!!

Re: start up problems

Posted: Wed Dec 19, 2018 3:56 pm
by guobl
following Chris suggestion point 3. I am thinking an alternative is :
1) install realcom as administrator and create a shortcut on desktop;
2) right click shortcut--> click property;
3) in the pop up window titled Imputation Properties, click Compatibility layer;
4) tick option "Run this program as an administrator" from the bottom of popup window;
5) press the OK button and realcom should work now.