errorr gcc compiler

Welcome to the forum for Stat-JR users. Feel free to post your question about Stat-JR here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

We will add further support to the Stat-JR website, such as FAQs and tutorials, as soon as it is available; the Stat-JR website can be found here:
Posts: 6
Joined: Fri Aug 22, 2014 4:59 pm

Re: errorr gcc compiler

Post by mithuabanerjee »

on typing that at the command prompt, I get:

g++.exe <GCC> 4.7.0 20111220 <experimental>
Copyright <C> 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

So, in summary it's version 4.7.0

best regards,
Soütrik Banerjee.
Posts: 59
Joined: Fri Oct 23, 2009 1:49 pm

Re: errorr gcc compiler

Post by richardparker »

Hi - thanks for the information. You seem to be running an older version of g++, from 2011. That's not a version we've tested Stat-JR with, so it's possible that may be contributing to the problem.

The .cmd file we sent you was meant to set the path to C:\MinGW\bin, but we've realised there was a mistake in the way we'd specified it - sorry. So it would have been using whatever compiler appears first in your path (which is likely to be the older version of g++, from 2011).

We've updated the .cmd file (attached) to explicitly set the path to C:\MinGW\bin. Assuming that is where you downloaded and installed MinGW when following the instructions here ( ... er-statjr/), that should ensure Stat-JR uses a more recent version of MinGW.

So, to run, please follow the instructions as before: i.e. unzip it and copy the command file into the directory in which Stat-JR is installed (e.g. C:\StatJR\TREE command.cmd), and then execute it.

If you still get the same problem, please check which version of g++ you have in C:\MinGW\bin by navigating to C:\MinGW\bin in Windows Explorer, pressing shift and right-clicking, then selecting Open command window here, and typing g++ --version at the prompt.

We would be grateful if you could let us know the outcome.

Many thanks,

(179 Bytes) Downloaded 482 times
Posts: 6
Joined: Fri Aug 22, 2014 4:59 pm

Re: errorr gcc compiler

Post by mithuabanerjee »


Thanks a lot, the problem is solved now !

Instead of running from the "start > CMM > StatJR TREE" menu, I ran the new TREE command.cmd saved at the location "C:\StatJR".

I also checked (by right clicking on the command prompt here at the "C:\StatJR\bin" folder location) the newer MinGW version installed (after the bug correction procedure as suggested in the website for StatJR installation) at the same location (i.e., C:\) of StatJR. It now gives 4.8.1 (and not 4.7.0).

Best regards.
Post Reply